Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 10, 2024 - 22:00 EDT
Scheduled
We would like to inform you that we will be conducting scheduled maintenance on our system to ensure continued improvements and service reliability.
During this period, our services may be temporarily unavailable or experience intermittent disruptions. We are working hard to minimize the impact and complete the maintenance as quickly as possible.
We apologize for any inconvenience this may cause and appreciate your understanding as we strive to improve our services for you.
Posted Sep 08, 2024 - 10:51 EDT
This scheduled maintenance affected: Speech Analytics (Transcription, Insights, Speaker Identification), Brooke - Digital Voice Assistant (Brooke - DVA Service, Brooke - Connection to Service Scheduler, Brooke Application), and CallerCX/BDC Central (BDC Central Application, Node F, Node G, Node D2).